Back to overview
Downtime

Upstream provider is experiencing issues

Jun 12 at 02:04pm EDT
Affected services
Telemetry

Resolved
Jun 12 at 04:41pm EDT

Service has been restored.

Updated
Jun 12 at 04:18pm EDT

Upstream provider is starting to recover, but services are not fully restored just yet.

Created
Jun 12 at 02:04pm EDT

The only affected service is telemetry, the app and backend servers continues to operate as normal. Follow updates here: https://www.cloudflarestatus.com/incidents/25r9t0vz99rp.